I am here

落尽红樱君不见,轻绘梨花泪沾衣

局部安装webpack提示拒绝安装本身的依赖

学习webpack的时候,局部安装webpack出现以下错误:

npm ERR! Windows_NT 6.1.7601 
npm ERR ! args "F:\Nodejs\node.exe" "F:\Nodejs\node_modules\npm\bin\npm-cli.js" "install" "webpack" "--save-dev" 
npm ERR! node v5.10.1 
npm ERR! npm v3.8.3 
npm ERR! code ENOSELF 
npm ERR! Refusing to install webpack as a dependency of itself

提示拒绝安装WebPack的本身的依赖

后来网上搜索发现,由于我的项目名就叫webpack,所以在生成package.json时,name也为webpack,导致无法安装,通过修改package.json里的name解决该问题。

disclaimer

本站只提供资讯,不提供任何上传下载服务,所有内容均来自分享站点所提供的公开引用资讯。 如果有版权违规内容,请通知作者删除。

本站不支持IE8浏览器 如果网页显示不正常,请升级到IE9及以上 推荐使用 Firefox、Chrome 等专业浏览器。